Sonicfire Pro Upgrade

I know of at least one reader who uses Sonicfire Pro.  When you upgrade to Snow Leopard (10.6), you will need to patch Sonicfire Pro.  Maybe I just missed the obvious, but te location of the patch, and the fact that it was specifically designed for 10.6, escaped me.  When I told Sonicfire Pro to check for updates, it told me I was up to date.

Without the update, attempting to play a file in SmartSound Express Track opens a save dialogue box.  Ug!
Link to your cure is here.